Ford Mustang Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I think I have a good list of everything I'm going to replace to try and fix the horrible gas milealge my car is getting. I've been averaging between 9 and 11 in the city. BLEH! So here is what I'm thinking of replacing:
-Plugs
-Cap & Rotor
-Plug Wires
-Coolant Temp. Sensor
-Oxygen Sensors (Question: my car has had its computer changed to an A9L from a 91GT, so I need 91GT oxygen sensors correct?)
-Fuel filter
-Clean my K&N
-Just cleaned my AFM w/ carb clean

Is there anything else that anyone can think of that would be causing gas mileage to dip that low? I don't constantly have my foot to the floor or anything. Thanks for any suggestions.
 
G

·
You should also replace your pcv valve while you're at it, and maybe your intake air temp sensor. I doubt there's a difference in the oxygen sensors, you should only need to get 91 sensors if you had to change them with the maf conversion. Do you have stock rear-end gears?
 

·
Registered
Joined
·
897 Posts
[QUOTE='95.0 stang]You should also replace your pcv valve while you're at it, and maybe your intake air temp sensor. I doubt there's a difference in the oxygen sensors, you should only need to get 91 sensors if you had to change them with the maf conversion. Do you have stock rear-end gears?[/QUOTE]
Second the above, I would also add changing the mesh screen underneath the PCV, checking ign timing and setting it to 12° - 14° btdc and checking fuel pump pressure. GL


 

·
Registered
Joined
·
4,809 Posts
Engine coolant temperature and bap sensor can also cause a constant rich condition.

Double check your tires air pressure too
 

·
Registered
Joined
·
93 Posts
Omen88LX said:
I think I have a good list of everything I'm going to replace to try and fix the horrible gas milealge my car is getting. I've been averaging between 9 and 11 in the city. BLEH! So here is what I'm thinking of replacing:
-Plugs
-Cap & Rotor
-Plug Wires
-Coolant Temp. Sensor
-Oxygen Sensors (Question: my car has had its computer changed to an A9L from a 91GT, so I need 91GT oxygen sensors correct?)
-Fuel filter
-Clean my K&N
-Just cleaned my AFM w/ carb clean

Is there anything else that anyone can think of that would be causing gas mileage to dip that low? I don't constantly have my foot to the floor or anything. Thanks for any suggestions.
Have you cleaned the mass air flow sensor wire.Use a electrial cleaner and be very carful as you can breake the two wires.That might help. Over oiling the K&N tends to get oil transfered on the wire then dirt accumulates on it. :rolleyes:
 

·
Registered
Joined
·
93 Posts
Do a wheel alingment. Alot of people don't know what you lose up to 20% in gas milage because of bad wheel alingment and airpressure in tires. The mesh screen that was suggested can be bought at ford it cost about $7. I took mine out with a long pair for needle nose pliers.

I did alot of things like your doing to yours so that I could find that extra milage. I was getting about 140 per tank in the city. Did the wheel alingment, changed out my mesh screen, pcv, coolent temp sensor, O2 sensors, plugs wires, cap, rotor, fuel filter, and checked the timing. I now get 200 per tank (city only). and that's with about a gallon and half left in the tank. so about 14.8 per mile. Not bad for having a full exhaust system and 3.73 gears. I'm sure that I would get maybe another .5 to 1 mile per gallon if I had smaller gears.:drool:
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Mine does have 3.73s in it. Which is part of the problem. On the highway at 70, the engine is doing around 1950rpm.
 

·
Registered
Joined
·
4,809 Posts
Mine does 60 mph @ 2000 rpm with 3.73 gears.
 

·
Registered
Joined
·
93 Posts
If your getting 1950 rpms at 70 mph then your not running 3.73's, maybe 2.73's. When I run at 70 i'm at like 2400 rpm's (give or take a little). If you got this car used and you were told that you had 3.73's then they lied to you (sorry).
 

·
Registered
Joined
·
4,809 Posts
blkgt50 said:
If your getting 1950 rpms at 70 mph then your not running 3.73's, maybe 2.73's. When I run at 70 i'm at like 2400 rpm's (give or take a little). If you got this car used and you were told that you had 3.73's then they lied to you (sorry).
I was thinking "whoa , maybe i have 4.10's" , but I did the driveshaft rotations divided by 10 wheel rotations and got 37.
 

·
Registered
Joined
·
136 Posts
Quick question, I tossed the wire mesh basket under the pcv when I did my intake manifold. It was completely plugged. I don't think this really can harm anything by not having it there. I haven't ever seen a basket filter on any other car I've owned. Not that this really matters since its getting a fresh engine anyway next month.
 

·
Registered
Joined
·
93 Posts
The reason that it's there is to stop oil from going up into the pcv valve.
 

·
Registered
Joined
·
93 Posts
hey ghostdog 5.0 I'm running the same rpm's as you at 60 so i'm sure that you have 3.73's.
 

·
Registered
Joined
·
579 Posts
you have some real tuning issues to get that kind of mileage with gears or not. If your O2s are bad you would be a smoke cloud when driving because you would need to be really rich for that kind of mileage. Did you unhook the MAP sensor on the firewall when you converted to MAS from SD? You need to make sure your firing on all cylinders all the time. Did this mileage start right after you converted to MAS? I get over 20mpg making over 500whp daily and never have I made under 15mpg even when road racing all day or drag racing all weekend. Don't just throw money at the car. Think back when this started then work from that point.
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top