Ford Mustang Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
Hi All,
My turn signals (right and left) are not working. Hazard flashers are working. I checked all the fuses and they are fine. Then I noticed a loose wire near the brake/clutch pedal. I thought it would be an easy fix but I can't figure out where exactly the wire goes. It seems there's a black DLC or something (relay ? ) above a yellow strip where it should go. But I cannot get to connect it. I am attaching pictures and hoping someone would help.

It's a 2003 V6 Mustang.

Thanks in advance.
 

Attachments

·
Registered
Joined
·
408 Posts
Two things other than checking fuses:
The turn signal relay down under steering wheel but most likely the multi function switch (turn signal/washer handle) that bolts on to the steering column.
Good luck. Post what you get done.
 

·
Registered
Joined
·
98 Posts
I take it you don't have cruise control. I believe that is the harness connector for the brake pedal cruise control shutoff switch.

Do your windshield wipers, high beams or flash to pass work?
 

·
Registered
Joined
·
114 Posts
Discussion Starter #4
No, I do not have cruise control. And the high beam does work. Wipers work too. Hazard lights work too.

So the loose wire is supposed to be loose ? Cos it's for cruise control and I don't have cruise control ?

Thanks for the responses.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #6
Thanks for the posts.

So now, should I even bother with the flasher since the hazard lights are working ? Just go and replace the multi-function switch ?
Also, do I need a torque screw driver or a steering wheel puller for a 2003 v6 mustang ? Different sites/posts seem to suggest different things.

Thanks.
 

·
Registered
Joined
·
6,859 Posts
Check fuse F2.18. F2.13, F2.33, and F2.41.

Work the hazard button in and out. The turn signals pass through the hazard switch contacts.

Check ground G204 located behind the center console. It is shared with the radio and is sometimes messed with during a radio install.

Also note, there are two halves to the flasher module. Can't assume because the hazards flash, that the flasher is good (most likely it is).

The multi-function switch can be rebuilt. Take your time and a lot of pictures. Clean and light sand the contacts. Regrease with di-electric grease.

Might also consider getting a replacement from the local salvage yard. Rebuild it. That way you are not risking your DD.
 

·
Registered
Joined
·
98 Posts
To remove: You simply need to pull the plastic shroud from around the steering column, just a few screws. To remove the key tumbler, insert key and turn to "run" but do not start the car, then directly underneath insert a small but long screwdriver or similar into the "empty" hole. Press on the indentation while pulling out on the tumbler. The multi function switch is just held in by a few screws and electrical connections. Install basically reverse, just reinsert tumbler in the same orientation as which removed.

Better to disconnect battery first. And use your best judgement on removing pieces.
 

·
Registered
Joined
·
408 Posts
just a quick FYI for future- The wire harness for lights/turnsignals is the bundle behind/below the clutch pedal.
 

·
Registered
Joined
·
71 Posts
Your hazard lights will still work even if you have a malfunctioning flasher, but it's not gonna be on/flashing for a long time. Have you tried to turn the flasher on for more than a minute or so?

If you found the problem, keep us posted. :bigthumbsup
 

·
Registered
Joined
·
114 Posts
Discussion Starter #12
I replaced the multi function switch but the problem still persists. Can someone tell me where the turn signal flasher is ? They Haynes manual says it's a white piece next to the fuse panel under the dash but the picture in the Haynes manual seems for older models and there's nothing similar in the 2003 mustang. I can see a black box next to the fuse panel. I also see a yellow piece on the right under the dash. I read on one of the posts that it's that one. Can anyone point me in the right direction ?

Thanks.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #13
btw, I have checked all the fuses as suggested above and they all seem to work. I also had the hazard lights running for a few minutes and it the hazard lights kept flashing for the entire time.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #14
I removed yellow flasher and the hazard lights don't work after that. Not sure if the flasher is still the culprit but I am going to replace it and find out. I couldn't find a replacement flasher at local auto stores so far.
 

·
Registered
Joined
·
114 Posts
Discussion Starter #15
I replaced the yellow flasher and the turn signals work now. The replacement flasher I got has 5 prongs and is missing the the sixth prong that the original flasher had, probably the one used for ground..Does that matter ?
 
1 - 15 of 15 Posts
Top