Ford Mustang Forum banner

1 - 20 of 58 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Thank you everyone in advance who will read this.

In short. I have a 2006 Mustang GT Automatic. I purchased a C&L Racer CAI with a custom 87,91,93 octane Brenspeed Tune. Installed everything myself.

When I first tuned the car with the 87 tune. It was like night and day. Truely worth the time/money.

But after driving it for 2-3 weeks now...I feel that the tune has lost its edge. It feels more sluggish than it did.

The weird/funny thing is, when I re-install my 87 tune it drives great. Great throttle response, great torque increase. But the more I drive it (day or two)...the feeling wears off. It over revs and feels like its sucking in more air than necessary

Am I missing something here? Just as a side note. Not to take away from the main question. The 91, and 93 tune feel less powerful than the 87.

Again thank you all!

- Joe -
 

·
Premium Member
Joined
·
72,878 Posts
That's pretty common. That's the PCM's adaptive learning that does that. Reflashing or disconnecting the battery resets everything.
 

·
Registered
Joined
·
10,876 Posts
No you didn't miss anything. These cars have what call adaptive learning. It learns how you drive and it will do that. I stomp on mine about ever other time I drive mine. And it still does it a little.

Talk with the guys at Brenspeed and see what they say. It can be turned off.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
That is what I kind of thought. How will I ensure that I will have that just re-installed tune feeling from now on? Thanks again
 

·
Registered
Joined
·
40 Posts
Discussion Starter #6
Okay. Thanks. I feel that it would be best to turn it off. Will this cause any future problems if turned off? I feel the tune looses its true potential with the adaptive learning done by the car.
 

·
Premium Member
Joined
·
72,878 Posts
Okay. Thanks. I feel that it would be best to turn it off. Will this cause any future problems if turned off? I feel the tune looses its true potential with the adaptive learning done by the car.
I have it turned off on my tune.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
I'll follow up with them tomorrow. STL thanks for everything.

It doesn't make sense to spend the time/money on a tune to let your adaptive learning re-think out the performance.

I figure since my Mustang is a daily driver...the adaptive learning hurts me during traffic.

STL who has done your tune?
 

·
Banned
Joined
·
822 Posts
...When I first tuned the car with the 87 tune. It was like night and day. Truely worth the time/money.

But after driving it for 2-3 weeks now...I feel that the tune has lost its edge. It feels more sluggish than it did.

The weird/funny thing is, when I re-install my 87 tune it drives great. Great throttle response, great torque increase. But the more I drive it (day or two)...the feeling wears off. It over revs and feels like its sucking in more air than necessary

Am I missing something here?...
Joe, I've found exactly the same with my 91 octane tune from them. I recently switched to a Bamachips tune, and hoping things will improve with it. So far, I like it better, as my bottom-end torque is still here..:) I found that a long freeway cruise really took the "edge" off of my Brenspeed tune (lost low-end grunt), and it felt worse than with the stock tune.
I hadn't been driving my Mustang the past few days, so really not had the chance to thoroughly test out the Bama tune. Hopefully, next week for another long freeway cruise, and then mountain canyon test..
 

·
Premium Member
Joined
·
72,878 Posts
I'll follow up with them tomorrow. STL thanks for everything.

It doesn't make sense to spend the time/money on a tune to let your adaptive learning re-think out the performance.

I figure since my Mustang is a daily driver...the adaptive learning hurts me during traffic.

STL who has done your tune?
I've had many. I'm currently on a dyno tune by Excessive Motorsport, Manassas, VA.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #14
Alright. Emailed Brenspeed. According to them my adaptive learning has already been turned off by the tunes.

I'm confused. It drives completely different. Nothing like when I first flashed the tunes into my car. I am getting less mpg. It is not as responsive. Feels like it consistently over-revs. Possibly worse than stock (based off performance).

I'm frustrated. I'm calling them tomorrow for a better answer. Anyone help?
 

·
Banned
Joined
·
822 Posts
...I'm frustrated. I'm calling them tomorrow for a better answer. Anyone help?
Try a Bamachips tune... I got frustrated with the Brenspeed as well. So far, so good with the Bama 91 torque tune.

Only thing I don't care for (with both Bama and Brenspeed) is that the cooling fan is always running when it's warmed up.
I understand why, but don't like to hear it...
 

·
Registered
Joined
·
494 Posts
You guys are scaring me.......
 

·
Registered
Joined
·
858 Posts
Ive had a bunch of Brenspeed tunes and i they are great. Are you using the correct octane for the tune? Try using a different gas station? Did you empty your tank before you switched to a tune with a different grade?

If it was fine for 2 weeks., it shouldnt just get sluggish unless something changed or stopped working.
 

·
Banned
Joined
·
822 Posts
...If it was fine for 2 weeks., it shouldnt just get sluggish unless something changed or stopped working.
Right; it shouldn't have. For some reason though, it does change... At least it changed on my car, and some others noted that it changed on theirs, too. Their answer was that a re-flash cures the problem, temporarily. I'm wondering if it has something to do with the computer code...? Mine is VBV1, BTW.
 
1 - 20 of 58 Posts
Top