Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
I didn't know what else to call it. I'll be doin roughly 65, I'll let the throttle off to about 1/4 and the whole car does a weird skip/surge thing. It sounds and feels like its getting fuel intermittently, but if that were the case I'd thing it would happen all the time. I can hear the thud of my u-joints, they're pretty worn out. Anyone have any idea?


Thanks,
Apollo34
 

·
Registered
Joined
·
283 Posts
check the fuel pressure, check your plugs and wires too
 

·
Registered
Joined
·
5 Posts
Hey I have a similar problem and am looking for answers or people with similar problems. My stang is a 92 FI/electronic ignition. seems to run fine except when the trans goes to OD. At 45-55 mph I get a constant skip. When I acceperate it goes away.

Did you come up with a fix?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #4
No not really, my buddy who's wa more mechanically inclined then me said that it could be the exhaust leak I have right out the exhaust manifold. The exhaust pipe and manifold are separated a bit.
 

·
Registered
Joined
·
1 Posts
Two ideas, your engine is misfiring or your u joints are shot. First check that you have all wires going to correct cylinders (probably do) more likely to solve this problem get a set of new spark plug wires (get silicon insulated ones), and a cap and rotor for distributor (2.3 has distributor right?) and new spark plugs. A worn u joint will give vibration in gears 2 3 and 4 but will not go away with higher rpm or when out of overdrive.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
Two ideas, your engine is misfiring or your u joints are shot. First check that you have all wires going to correct cylinders (probably do) more likely to solve this problem get a set of new spark plug wires (get silicon insulated ones), and a cap and rotor for distributor (2.3 has distributor right?) and new spark plugs. A worn u joint will give vibration in gears 2 3 and 4 but will not go away with higher rpm or when out of overdrive.
Nah, my joints are all good. Found out my clutch is bad though, lol. And I'm pretty sure I found out what it is. With the exhaust leak right in front of the O2 sensor, I think my car is dumping excess fuel to get higher carbon monoxide readings at higher speeds/rpms. It does the same thing at idle sometimes, so I figure once I get some exhaust tape on there it'll be okay.

Thanks!
Paul
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top