Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hi I Just Got A Clucth Cable But In On My 86 5.0 And Every Since Then I've Been Hearing This Ticking Noise Coming From Under The Car Also When I Rev The Car Up And Hold It Around 3 Rpm Or Higher U Could Hear The Clicking Noise It Sound Like Its Coming The Exhaust But Im Not Sure It Also Make The Cllickin Noise Wen The Car Is Just Sitting And Idealing So Do Anybody Know Wat This Could Be?
 

·
Registered
Joined
·
4,809 Posts
Whenever they removed the exhaust they might have not tightened everything down adequetely and you are hearing an exhaust leak.
 

·
Registered
Joined
·
4,809 Posts
I retract that last statement. I read clutch, not clutch cable... jumped the gun.
 

·
Registered
Joined
·
897 Posts
hyphyhighway said:
Hi I Just Got A Clucth Cable But In On My 86 5.0 And Every Since Then I've Been Hearing This Ticking Noise Coming From Under The Car Also When I Rev The Car Up And Hold It Around 3 Rpm Or Higher U Could Hear The Clicking Noise It Sound Like Its Coming The Exhaust But Im Not Sure It Also Make The Cllickin Noise Wen The Car Is Just Sitting And Idealing So Do Anybody Know Wat This Could Be?
Check the release fork. It might have been partially moved (misaligned) when the cable was installed, also check, if it hasn't been removed, that the release fork is not tapping on the cover. It happens.....GL
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top