Ford Mustang Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
242 Posts
Looks like it would go to the coolant temperature sensor.
 

·
Registered
Joined
·
268 Posts
Is it a carbed engine? Because that looks a lot like the MAF plug. I'm gonna go check mine out for a plug like that, I know I've seen it before.
 

·
Registered
Joined
·
268 Posts
Did I say MAF plug?  Haha, I was wrong, it is the coolant temp.  Joel was right.  Here's a picture of mine.   My middle finger is touching the place that
it plugs into.<br><br>http://s956.photobucket.com/albums/ae45/smrtbeenr/?action=view&current=07152011007.jpg<br>
 

·
Registered
Joined
·
101 Posts
Just checked because i cleaned my sensor 2day.There's two plugs.One plug goes to the coolant sensor on the black heater hose.The other one goes to a wire that runs down to under the alt/air box,where it looks like it splits and may run to both o2 sensors.I'll have to check those wires because my car is running rich.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #8
no its efi and its on the pass side. my coolent is on the driver side and its plugged in.. and i have a new ect sensor im installing 2moro..i like behind the alt but i have looked and cannot see anything missing anything.. i have my o2 harness installed as well... idk is there 2 coolant sensors? and yea i am running rich and i have anything post about that ....titled "getting codes and running rich?"
 

·
Registered
Joined
·
67 Posts
Discussion Starter #9
heres another pic...it looks like i have another ect sensor, its on the black tubes ( part of the heater hose system) but that sensor has a plug on it. both look the same too. my middle finger is on the sensor and you can see both plugs being i took off the one on the sensor. the other ect sensor is on the driver side just under the upper manifold.. i will have a pic 2moro for that just to make sure it is one.
 

Attachments

·
Registered
Joined
·
101 Posts
Maybe your car is different. Pic1 is the ECT. Pic2 is the Air charge sensor behind injector 5. Pic 3 is the mystery plug next to the ect.
 

Attachments

·
Registered
Joined
·
4,120 Posts
Maybe your car is different. Pic1 is the ECT. Pic2 is the Air charge sensor behind injector 5. Pic 3 is the mystery plug next to the ect.
Correct and that plug goes to the canister purge solenoid.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #14
ok well i think im missing all of that, and is it suppose to have a harness with it becuz i am looking online for one and all that i see have different plugs...mine is the roundish 2 prong like the ect...
 

·
Registered
Joined
·
4,120 Posts
The wires go downward to the canister purge solenoid which is close to you charcoal cannister, they're usually ran in a plastic shielding along with the vapor return hose.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #17
yea i went advance and it happened that one of the workers had a VERY nice coupe with alot of work..makes mine look crappy lol but i looked on his.. im missing the harness and the sensor.. so im looking now. but thanks for all the help.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #18
ok so the better question being that i forgot is that the vaccum line that the sensor in inline with where does it go up my the motor...
 
1 - 20 of 20 Posts
Top