Ford Mustang Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #1 ·
so i went and had my car inspected today.. it passed.. but in the list of OBD checks for evaporative system it said not ready when on my previous inspection the one immediately after i got my car it said ready.. what does that mean.. and what exactly is the Evaporative System?
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #3 ·
ooh so its environmentalist crap.. so any idea why OBD 2 would be saying the system wasnt ready? i had no codes or anything it runs fine and passed just wondering if theres a potential problem down the road for me
 

·
Registered
Joined
·
140 Posts
have you cleared codes or disconnected your battery recently? when you do that all of the emission components go through a self test and when they pass theyre "ready." if they dont pass within a certain number of times a code will set. if you havnt cleared the computer in any way you might want to check for pending codes or just drive it and if the check engine light comes on we will go from there
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #5 ·
well ive never had a check engine light since ive owned the car and so far as i remember the battery hasnt been disconnected in the past month or even more than that..
 

·
Registered
Joined
·
2,747 Posts
Any garage with a higher end scanner can force the test to run. Otherwise, it is a matter of on/off cycles for the ECM to do it by itself.
 

·
Registered
Joined
·
2,867 Posts
do you have a P1000 ?
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #8 ·
do you have a P1000 ?
u mean am i getting that code? no i have no codes never have.. its just on the inspection overview sheet it says the system was "not ready" when in the past it said ready.. am i worrying about nothing?
 

·
Registered
Joined
·
2,867 Posts
u mean am i getting that code? no i have no codes never have.. its just on the inspection overview sheet it says the system was "not ready" when in the past it said ready.. am i worrying about nothing?
this is what i meant:

diablosport.JPG
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #10 ·

·
Registered
Joined
·
2,867 Posts
sorry the picture is a little blurry.

this is a picture of my diablosport pulling a P1000 OBD2 Systems Readiness Test Not Complete off my car.

if you ever clear a CEL, this code will set for a little while.
(this code, however, does not trigger the MIL)
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #12 ·
oh i could read what was on the screen i was just wondering what the screen was part of... i see... well.. ive never had a code, cleared a code, nor checked for codes.. and i didnt know you could have a code without the light being on.. i also hadnt unplugged the battery nor opened the gas cap for at least 2 weeks before that and the engine had been running for quite a while waiting on the inspection line.. what are all the situations where that code will show the evap system not ready...

i just went outside plugged my sct tuner in and tried to read for any DTC's it said there werent any.. so.. no P1000..
 

·
Registered
Joined
·
2,867 Posts
i didnt know you could have a code without the light being on
you can also have a DTC pending, which wont trigger the MIL until it becomes a confirmed DTC. then it will trigger the MIL.

but, if you dont have codes, then you don't have a problem.
 

·
Registered
Joined
·
6,158 Posts
Discussion Starter · #14 ·
awesome.. thanks everyone.. now at least i know what the evaporative system is lol
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top