Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I have looked around the site and used the search box but I cant seem to find an answer for my question for the set up I have. I would like to know what other people are running for plugs and gap on similiar set up.

I have a 1993 GT with a built engine forged pistons, steel crank etc. that currently has around 1500 miles. I am running Trickflow heads, and intake, custom ground camshaft, shorty headers, 90 MM Ford MAF, with a Paxton Novi 1000 2 belt set up ( 5 PSI ). The car has been on the dyno a few times and tuned, it runs 426 RWH and 389 TQ. I know what plugs are in the car, and what the guy at the dyno shop told me but I am just curious what other people are running.

Thanks.
 

·
Registered
Joined
·
487 Posts
ngk 2771, 2 steps colder.

autolights are junk now, sold out to china an most the plugs come factory bad now
 

·
Registered
Joined
·
640 Posts
is 2 steps colder too much for 5 psi though?

on my other car i run 16 psi of boost and i'm 2 steps colder on the plugs.

i would start at one step colder, run the car hard and read the plugs to see if you should go colder. running a plug too cold can be bad for performance aswell
 

·
Registered
Joined
·
13,166 Posts
I run autolite my tuner runs ngk. either will work and the cheapys are the best. With 5 psi you should run one step colder. Your gap should be .035
 

·
Registered
Joined
·
55 Posts
Discussion Starter #7
Thanks for the input guys. I am running Autolite 3923's. I was just wondering what other people were running with a similair setup..the Autolites seem to work fine for me.
 
1 - 7 of 7 Posts
Top