Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
My car is backfiring a little, or more like a muffled backfire, when i let off the gas, and i suspect my timing is off.

What timing are you guys running? And what timing do you suggest on a slightly modded 5.0, headers, intake manifold, nothing too serious?
 

·
Registered
Joined
·
3,449 Posts
I have mine set around 13 1/2 or 14 and run Premium Gas. If your Timing is correct and you havent recently changed anything, I would start looking around to see what is causing your Afterfire.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
I'm guessing I might need new plugs, because I know I'm leakin oil into the #1 cylinder, so i need to change my plugs alot more, I'm workin on getting money to get that fixed but christmas is right around the corner and i need a new clutch
 

·
Registered
Joined
·
4,807 Posts
With my tweecer I run 14 degrees at part throttle and WOT, in neutral i run 10 degrees. If I didnt have tweecer I'd run 14 degrees.
 

·
Registered
Joined
·
47 Posts
14 degrees is a nominal advancement for 5.0s but with your valve seal leak and prominant backfire i would advance much at all or any, for the motors sake:weeps
 

·
Registered
Joined
·
47 Posts
14 degrees is a nominal advancement for 5.0s but with your valve seal leak and prominant backfire i wouldnt advance much at all or any, for the motors sake:weeps
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top