Ford Mustang Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
1,202 Posts
Discussion Starter · #1 · (Edited)
Well I am so happy I finally got my A/C working (kinda)

Problem 1. Sometimes it does not want to kick on. But I'm not worried cuase I will flush it again soon and fill it back up full. I think the freon is just at that point where sometimes the pressure switch will activate and sometimes it wont, so no biggie for now.

Problem 2. This one is bugging me. My A/C will cut out way before WOT. Sometimes it does it at 1/2 throttle and even as little as 1/4 throttle somtimes.

So what tells the WOT switch to kill the A/C? I am assuming it comes from the voltage signal at the TPS ? Is that correct or not? What can I tinker with to get it to only cut off at WOT? Should I pick up a differant TPS at the junkyard or a differant WOT relay? and see if it changes anything or should I be looking at something else?
 

·
Registered
Joined
·
5,170 Posts
The ECT sensor can also cut the A/C off. When the engine starts to run hot, the ECM signals the relay off, by the ECT reading
 

·
Registered
Joined
·
1,202 Posts
Discussion Starter · #3 ·
The ECT sensor can also cut the A/C off. When the engine starts to run hot, the ECM signals the relay off, by the ECT reading
Thanks thats good info for my memory.

But That cant be what my problem is. It works fine it just cuts out way before WOT. It sucks to just leave a light and it cuts out when the pedel is not even 1/2 way down.

As for sometimes it works and sometimes not. I belive it is the freon level. Some days I start the car and turn it on and nothing, other days I start the car and it works just fine. I am just going to cycle it for a while then drain it all and recharge it with fresh freon.

For now I just put a few cans of R-134 in with a can of dye and a can of oil. I just wanted to see if that old A/C system would work and it did. I was stoked to turn on the system and start filling it up. First can nothing, on the second can the system sensed the pressure and it kick on and started blowing cold air within a minute.:shiny:
 

·
Registered
Joined
·
5,170 Posts
Freon level is possible. Bit if the ECT sensor is giving false readings, it may be something to consider.

A KOEO or KOER test may confirm this, not sure.
 

·
Registered
Joined
·
1,202 Posts
Discussion Starter · #5 ·
Yeah, I should dump some codes. Just becuase.

It just pisses me off to hit 1/4 to 1/2 throttle and have the A/C shut off.
 

·
Registered
Joined
·
3 Posts
mustang

Hey it maybe to late maybe you got it fixed but if you have not I would try replaceing the wide open torttle a/c cut off relay!
 

·
Registered
Joined
·
621 Posts
The AC cutoff is part of an unchangable internal setting in the computer. It goes by throttle position and engine load.

I found it deep in Ford firmware descriptions for my A9L EEC IV.

Tom
 

·
Registered
Joined
·
1,202 Posts
Discussion Starter · #10 ·
Lost track of this thread, but I did think about swapping out the relay just for the heck of it.

But I want to throw my TPS on the voltage meter and see if it has a smooth transition when I open my throttle. Maybe the voltage spikes too soon. If so that would also effect my cars performance buy making it too rich too soon.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top