Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
So today I decided to install a new transmission cooler in my mustang, and I unhooked the battery so that I didnt accidently set off the airbag sensor. When I finished the installation and hooked everything back up the drivers side window wouldnt roll up. I tryed banging on the door panel, and got nothing. Its allways worked fine before, and wasnt slow or anything. I also allready checked for the fuse and couldnt find any bad wires. Could I of shorted something out when I unhooked the battery? let me know what you guys think, thanks.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #2
nevermind, I kept tapping on the motor with a screwdriver and it eventually went up.
 

·
Registered
Joined
·
241 Posts
Happened to me a couple of days ago and went online and saw this was a common problem... The gears would dry and would need a punch to jar it while holding the window switch up. Tried that and it came right up.

Sent from my PG06100 using Tapatalk
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Lol strange. That door panals a PITA getting back on though. Trying to get all those hooks to line back up.....yeeeesh.....
 

·
Registered
Joined
·
35 Posts
It might be the motor...

It might be a problem with the motor and probably you will have to replace it in a short term. My '02 was doing that for a while. Tapping or knocking the motor worked for a few days before getting stucked again. I think it is not related to the battery thing you just mentioned.

I ended up replacing the motor to finally solve the problem.
Good luck :bigthumbsup
 

·
Registered
Joined
·
2,881 Posts
Had that happen in my 03, one day the drivers window just wouldnt roll up. When i checked it the next day noticed if the wires were at a certain position it worked if not it didnt. My dad who helped me check it said it was a short and we straightened the wires and secured em. havnt had a problem since.
 

·
Registered
Joined
·
63 Posts
Possibly One-Touch-Up relay

Sounds like could be a loose component in the one-touch-up relay mounted under the foam on the back side of the panel. They seem to crap out after a few years but sometimes go slow. Can't fix it if it is going out, has to be replaced. Unfortunately, the local shops like Autozone, NAPA, etc... can't get them, dealerships don't get them from Motorcraft anymore as they are no longer produced. Have to get one online like RockAuto.com or something unless you want to make a trip to the salvage yard. Since this is typically cheaper and easier to replace than the window motor, best to check this if it stops going up and tapping or hitting the door/motor no longer works. If no dice, then go with the motor.
 
1 - 8 of 8 Posts
Top